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Which of the following statements will you use to delete a table from a database?

A. DROP TABLE <table_name>

B. DELETE TABLE <table_name> FROM DATABASE
C. REMOVE TABLE <table_name>

D. DELETE TABLE <table_name>

Answer: A

Explanation:

You will use the DROP TABLE statement to delete a table from a database. The syntax is as follows:
DROP TABLE <table_name>

Here, the DROP TABLE statement is used to drop the table and the <table_name> specifies the name of
the table to be deleted.

The DROP TABLE statement removes the table from the database. It can only be recovered if the backup
of the database is present.

Answer options D, C, and B are incorrect. There are no such types of statements available.

Reference: ECDL/ICDL Exam Course Manual, Contents: "DROP TABLE statement"

Chapter: DATABASE, ADVANCED-LEVEL

Objective: Query Design

Which of the following queries is used to see the relationship of data between two fields?

A. Parameter
B. Select

C. Action

D. Crosstab

Answer: D

Explanation:

A crosstab query is a powerful analysis tool used to see the relationship of data between two fields. It
calculates and restructures data for easier analysis. A user can use a crosstab query to calculate a sum,
average, count, or other type of total for data that is grouped by two types of information- one down
the

left side of the datasheet and one across the top. The cell at the junction of each row and column
displays the results of the query's calculation. This view is just like a spreadsheet with unique values of
one field as rows, unique values of another field as columns, and the summary of another field as the
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cells in the matrix. How to create a crosstab query?
Take the following steps to create a crosstab query:
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On the Open Recent Database page, click the required database.
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On the database window, click the Create tab.
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On the Create tab, click the Query Wizard.
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On the New Query dialog box, select the Crosstab Query Wizard, and click the OK button.
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On the Crosstab Query Wizard, select a table, and click the Next button.
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On the Crosstab Query Wizard, the columns of the selected table are displayed in the Available Fields list
box.
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| Crosstab Query Wizard
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On the Crosstab Query Wizard, move the columns from the Available Fields list to the Selected Fields list
by clicking on the > button. The >> button is not available in this wizard.

Click on the < button to move a field from the Selected Fields list to the Available Fields list. Click on the
<<button to move all the columns from the Selected Fields list to the Available Fields list. Select the Next
button.
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Crosstab QuensWizard
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On the Crosstab Query Wizard, select a column that will be displayed as the heading. Select the Next
button.
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On the Crosstab Query Wizard, select the function that is to be invoked on a column. Click the Next
button.
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Crosstab Querny Wizard
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On the Crosstab Query Wizard, select the View the query radio button, and click the Finish button.
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Department_Crosstab

The result of the query will be saved and displayed in the database window.
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Answer option A is incorrect. A parameter query prompts a user for information to be used in the query.

Answer option B is incorrect. A select query is used to retrieve data from one or more tables. It is used
to

display the results in a datasheet.

Answer option Cis incorrect. An action query is used to update multiple records in one operation.
Reference: ECDL/ICDL Exam Course Manual, Contents: "Crosstab query"

Chapter: DATABASE, ADVANCED-LEVEL

Objective: Table Design

Question:3
Order List

You have created an arithmetic expression in an Access query to compute the results that determine
fees

based on a contract amount. When you run this query, Access performs the calculations and displays the
results. Choose and re-order the steps that you will take to create the calculated field
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Click the OK button.

Type other values required to be included in the expression.
Double-click the field to be used in the calculation.

Click the Builder button.

Build an expression using the operator buttons and elements area.
Click the Run button.

Put the insertion point in the Field row.

Answer:

Click the OK button.

Type other values required to be included in the expression.
Double-click the field to be used in the calculation.

Click the Builder button.

Build an expression using the operator buttons and elements area.

Click the Run button.

Put the insertion point in the Field row.

Explanation:
Take the following steps to create a calculated field:
Put the insertion point in the Field row of a blank column in the Design grid.

11111111

Field: |Price Vendor Code Product [l
Table: | Products Products Products

Sort: | Ascending

Show: ]
Criteria:

on
Put the insertion point

Click the Builder button.

Vist usat: https.//www.certswarrior.com/exam/ecdl-advanced



Database Toals I Design

H }(' (10 Union -L::IE j*EInser‘t Fonis "'ﬁ_' Insert Calumns
= . '3 Pass-Through = Dielete Rows ‘-_"H" Delete Columns

Crosstab Delete Show 75 -
p{dData Definition | Taple DQ\ Builder ii,ﬁl Return: All ~

iy Type CUery Zetup

Double-click the field to be used in the calculation.

Build an expression using the operator buttons and elements area.
Type other values required to be included in the expression.

Click the OK button.

Expression Builder
Enter an Expression to define the calculated query field:
(Examples of expressions include [field1] + [field2] and [field1] = 5)
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Click the Run button.
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Reference: http://office.microsoft.com/en-us/access
Chapter: DATABASE, ADVANCED-LEVEL

Vidgit us at: https://www.certswar rior .com/exam/ecdl-advanced



Objective: Query Design

Question:4

You work as an Office Assistant for Company Inc. You are creating a presentation in PowerPoint 2010.
You

have created a button in the presentation. You want a program to run when you click on the button or
hover your mouse over it during the slide show. Which of the following will you use to accomplish the
task?

A. Reuse Slides

B. Hyperlink

C. Action

D. Set Up Slide Show

Answer: C

Explanation:

The Action icon feature is used to apply an action to the selected object in a slide to indicate what
should

happen when a user clicks on the object or hovers his mouse over it. Take the following steps to run a
program in a presentation:

1. Select an object.

2. Click on the Insert tab and select the Action option.

3. The Action Settings dialog box appears. Select the Run program radio button. Click the Browse button.
4. The Select a Program to Run dialog box appears. Select a program, and then click the OK button.

Note: Whenever a user clicks the object during a slide show, the selected program will automatically
run.

Answer option B is incorrect. A hyperlink is used to link a destination. However, it is not able to execute
any program efficiently.

Answer option A is incorrect. The Reuse Slides feature is used to reuse a slide from one presentation to
another presentation.

Answer option D is incorrect. The Set Up Slide Show option is used to set up the show type, show
options, pen color, and slide show resolution, for example, a slide show without animation. By using it, a
user can apply advanced options such as presented by a speaker.

Chapter: PRESENTATION, ADVANCED - LEVEL

Objective: Multimedia

Mark the option/button in the following image of the Format tab on which you will click to apply the
effect to a textbox.

Format

I.Tj) " - } & - L Bring Forward ~ |2 - Al
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[Abc ] &b Abe | |- 2 - &7 - L4 sendBackward = [F] :
Shapes Quick size
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Vist usat: https.//www.certswarrior.com/exam/ecdl-advanced



Answer:

Format
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Explanation:

A text box is a control that is rectangular in shape. A text box has a border that separates it from the rest
of the interface. A user can type the text inside a text box and resize it also according to his need. Take
the following steps to add shape effects to a text box:

Select the text box.

‘?
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Click the Format tab under Drawing Tools.

m Home Insert Design Transitions Animations Slide Show Revitw Wik Format

Click the Shape Effect button in the Shape Styles group.
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The Shape Effects drop-down list opens. Select an effect to be applied.
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Chapter: PRESENTATION, ADVANCED - LEVEL

Objective: Slides

Question: 4

Which of the following is a list of the references in a legal document, such as cases, statutes, and rules,
along with the page numbers on which the references appear?

A. Table of Authorities
B. Table of Contents
C. Table of Pictures

D. Table of Figures

Answer: A

Explanation:

Table of Authorities is a list of the references in a legal document, such as cases, statutes, and rules,
along with the page numbers on which the references appear.

Answer option B is incorrect. Table of Contents is a list of chapters and their sections of a book or a
document. Use the list along with the respective page numbers of the chapters and their sections for
easy navigation.

Answer option D is incorrect. Table of Figures is a list of the captions for pictures, charts, graphs, slides,
or other illustrations in a document. Table of Figures given along with the page numbers on which the
captions appear.

Answer option Cis incorrect. It is not a valid type of list.

Reference: ECDL/ICDL Exam Course Manual, Contents: "Table of Authorities"

Chapter: ADVANCED WORD PROCESSING

Objective: Collaborative Editing

You work as an Office Assistant for BlueSoft Inc. You use Microsoft Word 2010 for creating documents.
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You need to change the orientation of the page from portrait to landscape. Mark the tab that you will
use
to accomplish the task.
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Explanation:
You will click the Page Layout tab to change the orientation of the page from portrait to landscape. Click
the Orientation button, and select Landscape from the list.
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Chapter: ADVANCED WORD PROCESSING
Objective: Prepare Outputs

Question: 6
Which of the following steps will you take to remove background of slides?

A. Insert > Background Styles > Reset Slide Background
B. Format > Background Styles > Reset Slide Background
C. Design > Background Styles > Reset Slide Background
D. Design > Background Styles > Format Background

Vist usat: https.//www.certswarrior.com/exam/ecdl-advanced



Answer: C

Explanation:
Take the following steps to remove background of slides:
Click the Design tab.

Home Insert Design Transitions Animations Slide Show Rewview i

Select the Background Styles drop down menu in the Design tab. Click the Reset Slide Background option
to remove background of slides.

_|_|A
_|_|7

Answer options B, A, and D are incorrect. These are not valid steps to remove background of slides.
Reference: ECDL/ICDL Exam Course Manual, Contents: "Background of slides"

Chapter: PRESENTATION, ADVANCED - LEVEL

Objective: Pictures, Images, Drawn Objects

Which of the following view types allows a user to manipulate data on the form created in Access 20107?

<4 Format Background...
4?_‘] Reset Slide Background

A. Datasheet view
B. PivotTable view
C. Form view

D. PivotChart view

Answer: C
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Explanation:

The Form view is a default view type for an Access form. It allows a user to manipulate data on the form.
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Answer option A is incorrect. The Datasheet view displays the data in the table format.
Answer option D is incorrect. The PivotChart view allows a user to display the data of a form as pivot

charts.
Answer option B is incorrect. The PivotTable view allows a user to display the data of a form as a pivot

table.

Reference: http://office.microsoft.com/en-us/access
Chapter: DATABASE, ADVANCED-LEVEL

Objective: Form Design
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